'전체'에 해당되는 글 116건

왜 나는 영업부터 배웠는가 - 도키 다이스케





2014년 4월 Cisco 엔지니어에서 Sales로 업무 변경이 되었다.


8개월간 내가 생각하는 방식대로 무작정 열심히만 했는데 너무 많이 헤메었다.



서점에서 문득 눈에 들어온 책.


왜 이제서 읽게 되었을까.. 이 책은 아주 가볍게 영업이란 이런거야~ 라고 말하는 느낌.



책에서는 신뢰쌓기를 가장 우선시 한다. 


또한 신뢰 5단계로 구분하여 현재 고객과의 신뢰 상황을 파악하고 다음 신뢰 단계로 나아가기 위해 어떤 조치가 필요한지 알 수 있다. 


나는 "혹시 도움이 되실까 준비했습니다" 이 말이 너무 좋다.


당신생각을 하며 당신 입장이 되어 당신에게 도움이 될까싶어 준비했다는 것이 분명 내 이름 한 번은 더 기억하게 할 수 있지 않을까 생각을 하였다. 


고객이 필요한 것은 없는지, 이 자료를 전달하면 업무에 더 편의를 줄 수 있는지 등등. 고객의 입장에서 생각해 볼 수 있어 자주 활용할 예정이다.


책에서는 말하는 영업은 당연한 말들이 많다.


1. 고객이 왜 이상품이 필요한지 고민한다.

2. 실수를 한다면 성의있게 사과를 한다.

3. 계약이 무산될 경우 당신탓이 아니라며 다음 비지니스를 기약한다.

4. 구매 결정 패턴을 파악한다.

5. 사업 결정권자를 찾아낸다.


너무나도 당연한 말인데.. 이제 영업을 시작한 나로써는 한 문장 한 문장 어떻게 활용을 할지, 지금 상황에 적용시켜 본다.



어려운것을 쉽게, 쉬운것을 깊게, 깊은것을 재미있게. 


도키씨가 공감하였듯이 나 또한 이 마음을 진지하게 생각하며 나만의 영업을 시작해 볼까 한다.



'' 카테고리의 다른 글

왜 나는 영업부터 배웠는가  (0) 2015.01.04
멈추지 않는 도전  (0) 2012.01.22
홍대리 도서목록  (0) 2012.01.20
독서 천재가 된 홍대리  (0) 2012.01.20
스무살에 알았더라면 좋았을 것들  (0) 2012.01.18
바보처럼 공부하고 천재처럼 꿈꿔라  (0) 2012.01.16
0 0
ETC

올 한해 고생많았다며 선물로 주신 괴물 똑딱이 소니 RX100M3

​​​
너무 이쁨


뷰파인더와 플래시까지​


디스플레이 변형이 가능하여 더 매력적이네요

셀카 찍을 수 있는게 메리트입니다 ^^


가지고 다니며 똑딱 똑딱 찍는다고 하여 똑딱이

직접 찍어 WI-FI를 이용하여 아이패드로 옮긴 사진입니다



아이폰이 최고라고 했던말은 잠시 접어둬야겠네요


'ETC' 카테고리의 다른 글

최강 똑딱이 소니 DSC-RX100M3  (0) 2014.12.31
0 0
공부

 

VTP (Vlan Trunking Protocol)

 

 

VTP는 스위치 사이에서 VLAN DB정보를 교환하기 위한 Protocol이다.

필수 사항은 아니지만 대규모 네트워크 환경에서 관리 편의상 유용한 기능이다.

 

쉽게 말해 Server Switch에서 VLAN 정보를 설정하면 하위 Client Switch에 자동으로 동기화 된다는 뜻이다.

 

 

VTP 동작 조건

  - Switch간 연결은 반드시 Trunk로 설정되어야 한다.

  - VTP domain name은 일치하여야 한다. (대소문자 구분)

  - Revision Number를 일치하여야 한다.

  - Revision Number가 일치하지만 미동작한다면 VLAN 정보를 추가/변경/삭제 등의 Action을 취한다.

  - Revision Number를 0으로 초기화 하려면 Domain name을 변경한다.

 

 

VTP Mode

1. Server

    : Default 설정이다. Vlan 생성/수정/저장/삭제가 가능하다.

 

2. Client

   : Server와 통신하여 VLAN 정보 동기화. VLAN 생성/수정/저장이 불가능하다.

 

3. Transparent

   : 다른 Switch와 VLAN DB를 교환하지 않으며 자체적인 VLAN DB를 관리한다. VTP 메시지 수신과 전달은 가능하다.

 

 

 

VTP 동작 확인

 

1. TEST 구성도

 

2. Trunk, VTP 설정

 

 SW_1

 

Trunk 설정

Switch_1(config)# interface fa 0/1

Switch_1(config-if)# switchport trunk encapsulation dot1q

Switch_1(config-if)# switchport mode trunk

 

VTP 설정

Switch_1(config)# vtp domain Test

Switch_1(config)# vtp mode server

 

  SW_2

 

Trunk 설정

Switch_2(config)# interface fa 0/1

Switch_2(config-if)# switchport trunk encapsulation dot1q

Switch_2(config-if)# switchport mode trunk

 

VTP 설정

Switch_2(config)# vtp domain Test

Switch_2(config)# vtp mode client

 

 

 

 

3. VTP 설정 확인

 

Switch_1# show vtp status

 

 

 

 

4. VTP 동작 확인

 

 

A. Switch_2 에서 VLAN 정보 확인

 

Switch_2# show vlan

 

 

B. Switch_1 VLAN 설정

 

 

Switch_1(config)# vlan 30

Switch_1(config-vlan)# name VLAN_A

Switch_1(config)# vlan 40

Switch_1(config-vlan)# name VLAN_B

 

 

 

C. Switch_2 에서 VLAN 정보 확인

 

Switch_2# show vlan 

 

 

VTP Server 에서 VLAN을 생성하면 VTP Client에서 자동으로 VLAN이 생성된 결과를 확인했다.

소규모에서는 큰 효과를 얻기 힘들지만 대 규모 네트워크 환경에서 수 많은 스위치를 관리하기에는 적합한 Protocol 이다.

 

 

 

'공부' 카테고리의 다른 글

[Network] VTP (Vlan Trunking Protocol)  (0) 2013.10.31
EIGRP 1  (0) 2012.02.24
RIPv2  (0) 2012.02.24
CIDR 경로요약  (0) 2012.02.24
RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
0 0
여행

2013. 10. 25

 

일월산 단풍놀이

 

 

굽은 도로를 따라 단풍나무와 억새가 아주 멋있게 자리잡고 있습니다.

가을 드라이브 코스로 강추.

 

 

 

 

햇빛이 적절히

 

 

 

 

너무 멋진 길입니다.

 

 

 

 

신비롭기까지 하네요.

 

 

 

숨은 단풍코스

 

우연히 만난 멋진 길이라 기분도 덩달아 좋아지네요 :)

 

 

'여행' 카테고리의 다른 글

일월산 단풍  (0) 2013.10.30
청량산 산행 그리고 단풍놀이  (2) 2013.10.30
열두번째, 서울 억새축제  (2) 2013.10.22
대구 팔공산 동봉  (0) 2012.05.04
0 0
여행

2013. 10. 25

 

청량산 산행 그리고 단풍놀이

 

 

청량산은 경북 봉화군 명호면에 위치하고 있습니다.

낙동강이 흐르는 아주 멋진 곳이죠.

 

어릴적부터 자주 다녔던 곳 이지만 갈때 마다 늘 멋있다고 생각합니다.

 

 

먼저 청량산 청량사 사진으로 시작합니다.

 

 

 

 

다른 절에 비해 작은 편이지만 저는 오히려 더 좋네요.

요즘 청량산이 하늘다리로 많이 알려져 사람들이 예전에 비해 많아 졌습니다.

 

출발전 안내도를 확인하시고 등산 코스를 정하시면 됩니다.

우리는 입석 - 응진전 - 김생굴 - 자소봉 - 탁필봉 - 하늘다리 - 청량사 - 입석

왕복 4시간 걸렸습니다.

 

 

 

 

 

올라가다보니 좋은 글 귀들이 많이 있네요.

 

 

 

이것두

 

 

 

바닥에 떨어진 단풍이 참 예쁘네요.

 

 

 

 

날씨도 좋고

단풍도 좋고

하늘도 좋고

 

등산하기 너무 좋은 계절이네요.

 

 

 

 

청량산은 지금 단풍이 절정입니다.

 

 

 

 

색감이 너무 좋네요.

 

 

 

 

절이 보이기 시작하네요

 

 

 

 

아이폰5 파노라마 촬영입니다.

 

 

 

 

김생이 공부한 터가 보이네요.

 

 

 

 

경치 좋네요.

 

 

 

 

다람쥐 포착.

잘 찾아보세요

 

 

 

 

드디어 자소봉 도착

마지막 계단이 힘이드네요.

 

그리고.......

경사가 좀 있어서 무서움 주의.

 

 

 

자소봉에서 바라본 청량산입니다.

 

단풍이 절정이네요.

 

 

 

파노라마 촬영입니다.

청량산 너무 이쁘네요.

 

 

 

 

 

탁필봉을 지나 능선을 타고 하늘다리로 갑니다.

능선을 걸으며 보는 청량산은 강추.

 

 

 

 

방향 지시표가 아주 잘 되어 있네요.

 

 

 

 

드디어 하늘다리 도착.

 

조금의 흔들거림은 아주 간떨리게 하네요.

나도 덜덜덜

여자친구도 덜덜덜

 

공기가 상쾌해서 좋았고

날씨도 너무 맑아서 좋았고

오랜만에 등산이라 좋았고

함께여서 더 좋았습니다.

 

청량산 단풍놀이 끝.

 

 

 

'여행' 카테고리의 다른 글

일월산 단풍  (0) 2013.10.30
청량산 산행 그리고 단풍놀이  (2) 2013.10.30
열두번째, 서울 억새축제  (2) 2013.10.22
대구 팔공산 동봉  (0) 2012.05.04
2 0
노래

으쌰으쌰 - 신화

 

 

 

 

 

 

 

Hey! Come on everybody Swimming in the Sea-
Saying doo waa diddy diddy dum dee ree dum!
hey! come on everybody walking down the sea
saying doo waa diddy diddy dum dee ree dum

한밤중에 기차타고 가네 어린 시절의 바다찾아가네
걱정거리, 근심거리, 하나없던 그 시절로 돌아가고 싶어
Uh! 나 이제 피곤해요 일 그만 할래 요~
다 접어두고 우리 함께 물놀이 가면 안될까요~

uh! uh! uh! 으쌰으쌰
uh! uh! uh! hey hey hey Ho!
uh! uh! uh! 으쌰으쌰
uh! uh! uh! hey hey hey Ho!

시원하게 부서지는 파도, 햇살, 모래사장, 바다가 좋아
덥지도 않고 질리지도 않는 수박은 더 좋아
이렇게 좋은 여름을 기다려 온 나는 기분 좋아(덤디리 덤)

여름밤이 찾아오면 모닥불을 피워놓고 둘러앉아
이것저것 아무 재미없는 얘기도 할거야.
썰렁한 얘기라도 그런 밤엔 다 용서받고 싶어(덤디리 덤)

나나! 어릴적에 살던 동네 여름오면 너무너무 행복했지
시냇가에 친구들도 (첨벙첨벙) 덩달아 바둑이도 (깡총깡총)
그렇게 앉아 있지 말고 나랑같이가요(Oh~ baby)
안되는 일 억지로 붙잡고 늘어져서 된다는 보장 하나 없을테니까

인생을 낭비하지 마세요.
오 그렇게 살다보면 찌들어 가니까
한 번 이라도 툭툭털고 모든 걸 잊고 즐기며 살아봐요!

하루종일 지루하고 짜증나는 일이 많이 있었다면
이것저것 재보지 말고 여행을 떠나봐
기차를 타고 버스를 타고서 떠나자

Hey! Come on everybody Swimming in the Sea-
Saying doo waa diddy diddy dum dee ree dum!
hey! come on everybody walking down the sea
saying doo waa diddy diddy dum dee ree dum

인생을 낭비하지 마세요.
오 그렇게 살다보면 찌들어 가니까
한 번 이라도 툭툭털고 모든 걸 잊고 즐기며 살아봐요!

하루종일 지루하고 짜증나는 일이 많이 있었다면
이것저것 재보지 말고 여행을 떠나봐
기차를 타고 버스를 타고서 떠나자

uh uh uh Oh! baby baby Yeah-
uh uh uh uh hey hey hey Ho
uh uh uh Uh! 으쌰으쌰
uh uh uh hey hey hey ho

'노래' 카테고리의 다른 글

[노래] 신화 - 으쌰으쌰  (0) 2013.10.28
[Util] FLAC -> MP3 변환  (0) 2013.10.24
[노래] 김건모 - 아름다운 이별  (1) 2013.10.22
사랑 - 노사연  (0) 2012.02.29
니가 떠난 그날 - 먼데이키즈(Monday Kiz)  (0) 2012.02.28
Until You - Shayne Ward  (0) 2012.02.24
0 0
노래

 

FLAC -> MP3 변환

 

 

간혹 파일을 받아보면 확장자가 .flac로 되어 있는 경우를 본다.

사용하는 Device와 호환이 된다면 문제가 없지만 아닌 경우가 많다.

 

아래 파일은

flac 확장자를 흔히 알고 있는 mp3 파일로 변환하는 툴이다.

 

  FLAC2MP3_setup.exe

 

 

위 파일을 다운로드 하여 설치를 진행한다.

 

 

 

 

Next만 여러번 클릭하면 손 쉽게 설치 완료.

 

설치가 완료되면 아래와 같이 폴더에 파일들이 생긴다.

아래 파일 중 Convert Audio Free_FLAC2MP3.exe 파일을 실행시킨다.

 

 

 

실행파일을 실행하면 아래와 같은 화면을 만날 수 있다.

 

 

 

1. 파일 추가 및 제거

2. 변환 시작

3. 저장 될 폴더 선택

4. 설정

 

 

보다 고음질의 파일로 변환 하고자 한다면 4.설정 을 클릭하여 아래 사진의 Bitrate를 높이 설정하면 된다.

 

 

 

 

FLAC (free lossless audio codec)

MP3는 사람이 듣지 못하는 주파수 영역의 소리를 삭제하여 파일 용량을 줄이고, FLAC는 원 음원을 지우지 않고 파일만 압축해 용량을 줄인다. 따라서 원본 오디오와 비교하여 음원의 손실이 없다는 것이 FLAC의 장점이다

[참조] 네이버 지식백과 (http://terms.naver.com/entry.nhn?docId=932653&cid=2958&categoryId=2958)

 

 

MP3

MP3란 음악 등 각종 오디오용 데이터를 저장한 컴퓨터 파일로, 디지털 음악매체이다. 'MPEG-1 Audio Layer-3'의 약자로 지난 1995년 영상압축 표준인 MPEG기술 가운데 음성부분이 따로 떨어지면서 등장했다. 즉, MP3는 오디오 데이터의 압축기술로서, MPEG-1과 MPEG-2의 기능 사양 중 일부이다

[참조] 네이버 지식백과 (http://terms.naver.com/entry.nhn?docId=74682&cid=418&categoryId=418)

 

 

'노래' 카테고리의 다른 글

[노래] 신화 - 으쌰으쌰  (0) 2013.10.28
[Util] FLAC -> MP3 변환  (0) 2013.10.24
[노래] 김건모 - 아름다운 이별  (1) 2013.10.22
사랑 - 노사연  (0) 2012.02.29
니가 떠난 그날 - 먼데이키즈(Monday Kiz)  (0) 2012.02.28
Until You - Shayne Ward  (0) 2012.02.24
0 0
노래

아름다운 이별 - 김건모

 

 

 

 

 

 

아름다운 이별 - 김건모

 

 

눈물이 흘러 이별인걸 알았어
힘없이 돌아서던 너의 뒷모습을 바라보며
나만큼 너도 슬프다는 걸 알아
하지만 견뎌야해 추억이 아름답도록

그 짧았던 만남도 슬픈 우리의 사랑도
이젠 눈물로 지워야할 상처뿐인데

*내 맘 깊은 곳엔 언제나 너를 남겨둘꺼야
슬픈 사랑은 너 하나로 내겐 충분하니까
하지만 시간은 추억 속에
너를 잊으라며 모두 지워가지만
한동안 난 가끔 울 것만 같아

두 눈을 감고 지난날을 돌아봐 그 속엔
너와 나의 숨겨둔 사랑이 있어
언제나 나는 너의 마음속에서
느낄 수 있을 거야 추억에 가려진채로

긴 이별은 나에게 널 잊으라 하지만
슬픈 사랑은 눈물속의 널 보고 있어

*내 맘 깊은 곳엔 언제나 너를 남겨둘꺼야
슬픈 사랑은 너 하나로 내겐 충분하니까
하지만 시간은 추억 속에
너를 잊으라며 모두 지워가지만
한동안 난 가끔 울 것만 같아

'노래' 카테고리의 다른 글

[노래] 신화 - 으쌰으쌰  (0) 2013.10.28
[Util] FLAC -> MP3 변환  (0) 2013.10.24
[노래] 김건모 - 아름다운 이별  (1) 2013.10.22
사랑 - 노사연  (0) 2012.02.29
니가 떠난 그날 - 먼데이키즈(Monday Kiz)  (0) 2012.02.28
Until You - Shayne Ward  (0) 2012.02.24
1 0
여행

 

 

열두번째 서울 억새축제.

 

10월은 너무나 풍성하다.

축제도 많고, 먹을거리도 많고, 볼거리도 많다.. 그리고  일도 많네 :(

 

날씨 좋은 날 너무나 걷고 싶었다.

바람도 선선하고 햇빛도 따사롭다.

 

 

입구에서 축제를 알린다.

 

 

10여분을 걷고 걸어 드디어 하늘공원 정상에 도착.

억새가 억수로(사투리) 많다.

 

 

 

 

여기저기 커플들이 많다.

물론 부럽지 않다. 나도 커플이니까 :)

 

 

노을도 멋있고, 바람도 좋고.

 

 

 

 

전망대에서 바라보는 서울.

 

 

전망대에서 바라보는 야경이 더 멋있다.

사진은 아이폰5으로 촬영한 것이니 화질은 Pass.

 

 

내려오는길 불을 밝혀주는 등.

 

아쉬운 점 한가지

양쪽에 등이 달려있다면 좀더 밝고 안전하지 않을까 하는 생각.

 

 

가는 길은 아래 지도를 참조.

정확한 길을 찾고 싶다면 아래 주소를 확인.

 

(서울 억새축제 홈페이지)

http://worldcuppark.seoul.go.kr/parkinfo/parkinfo1_4.html

 

 

 

 

좋은 날

좋은 사람과

의미있는 이야기를 나눈

즐거운 데이트였습니다.

 

안녕 :)

 

 

 

 

 

 

'여행' 카테고리의 다른 글

일월산 단풍  (0) 2013.10.30
청량산 산행 그리고 단풍놀이  (2) 2013.10.30
열두번째, 서울 억새축제  (2) 2013.10.22
대구 팔공산 동봉  (0) 2012.05.04
2 0
여행

팔공산 동봉


혼자서는 처음하는 등산이라 걱정도 했지만 나름 낭만이 있는 듯 했습니다.


대구에서 버스를 타고갔는데 급행 1번을 타시고 동화사 또는 종점에 내려서 올라가시면 됩니다. 


버스로 40분~50분 정도 소요됩니다.













 




'여행' 카테고리의 다른 글

일월산 단풍  (0) 2013.10.30
청량산 산행 그리고 단풍놀이  (2) 2013.10.30
열두번째, 서울 억새축제  (2) 2013.10.22
대구 팔공산 동봉  (0) 2012.05.04
0 0
노래
사랑 - 노사연



그때는 사랑을 몰랐죠 당신이 힘든 것조차

받으려고만 했었던 날, 그런 세월만 갔죠


어두운 밤이 지나가고, 새벽이 오는 것처럼


오직 나 위한 그 마음을 이제야 느낄 수 있죠


고마워요 오랜 그 시간 끝없는 당신의 사랑


이제 다시 꿈을 꾸어요 모든걸 드릴께요


하루,하루 당신 볼 때마다 난 다시 태어나죠


천번 만번 하고 싶은 말 듣고 있나요


사랑해요


고마워요 오랜 그 시간 끝없는 당신의 사랑


이제 다시 꿈을 꾸어요 모든걸 드릴게요


하루, 하루 당신 볼 때마다 난 다시 태어나죠


천번 만번 하고 싶은 말 듣고 있나요


하루, 하루 당신 볼때마다 난 다시 태어나죠


자꾸 자꾸 눈물이 나요 듣고 있나요


사랑해요


 

'노래' 카테고리의 다른 글

[Util] FLAC -> MP3 변환  (0) 2013.10.24
[노래] 김건모 - 아름다운 이별  (1) 2013.10.22
사랑 - 노사연  (0) 2012.02.29
니가 떠난 그날 - 먼데이키즈(Monday Kiz)  (0) 2012.02.28
Until You - Shayne Ward  (0) 2012.02.24
Rolling in the Deep - Adele  (0) 2012.01.16
0 0
노래
니가 떠난 그날 - 먼데이키즈(Monday Kiz)


몰랐었어 몰랐었어 
혹시나 하는 맘도 없었어 
설마 너의 맘이 변해 버릴줄 말야
몰랐었어 몰랐었어 
이렇게 나를 두고 갈 껀지 
차라리 잘해주지를 말지 왜 날 이렇게

어제까지는 사랑이고 
오늘은 이별이 말이 되니 
지난 사랑이 모두 거짓말 인거니

니가 떠난 그날 나를 버린 그날 
너와나의 추억이 모두 사라진 날
널 다시는 안보겠다고 눈물로써 맹세한 날
뒤를 돌아볼까 혹시 니가 올까 
지금이라도 너를 향해 뛰어볼까
하지만 돌릴 수 없는 니 맘 
나를 두고 떠나간 날 니가 떠난 그날

참아봤어 참아봤어 
너를 꼭 잡고 싶은 나의 맘
니 앞에서 눈물 흘리면 올까 혹시
참아봤어 참아봤어 
너에게 소리치고 싶은 맘 
사랑이 어떻게 변하냐고 말하고 싶어

어제까지는 사랑이고 
오늘은 이별이 말이 되니 
지난 사랑이 모두 거짓말 인거니

니가 떠난 그날 나를 버린 그날 
너와나의 추억이 모두 사라진 날
널 다시는 안보겠다고 눈물로써 맹세한 날
뒤를 돌아볼까 혹시 니가 올까 
지금이라도 너를 향해 뛰어볼까
하지만 돌릴 수 없는 니 맘 
나를 두고 떠나간 날 니가 떠난 그날

가지말라고 떠나지 말라고 
눈물을 참고 너에게 말을해
돌아오라고 나에게 오라고 
소리치고 울던 날 니가 떠난 그날

나를 떠난 그날 사랑이 떠난 날 
마지막으로 너의 얼굴을 본 그날
너 없이는 살수없다고 눈물 흘리며 말한 날
제발 돌아와줘 떠나지 말아줘 
지금보다 더 너를 사랑 할 수있어
누구보다 더 소리쳤던 날 
결국 나를 두고 간 날 니가 떠난 그날





'노래' 카테고리의 다른 글

[노래] 김건모 - 아름다운 이별  (1) 2013.10.22
사랑 - 노사연  (0) 2012.02.29
니가 떠난 그날 - 먼데이키즈(Monday Kiz)  (0) 2012.02.28
Until You - Shayne Ward  (0) 2012.02.24
Rolling in the Deep - Adele  (0) 2012.01.16
No Promises - Shayne Ward  (0) 2012.01.16
0 0
공부



EIGRP


EIGRP (Enhanced Interior Gateway Routing Protocol)는 디스턴스 벡터,클래스리스 라우팅 프로토콜이다.

EIGRP는 Cisco IGRP (Interior Gateway Routing Protocol)을 향상시킨 프로토콜이다.
이 두 프로토콜은 모두 시스코의 독자적인 프로토콜로서 시스코 라우터 상에서만 동작한다.


기존 디스턴스 벡터계열 라우팅 프로토콜과 비교하여 새로운 특징
- RTP (Reliable Transport Protocol)
- 제한된 범위에서의 업데이트
- DUAL (Diffusing Update Algorithm)
- 인접성 설정
- 이웃 및 토폴로지 테이블


IGRP를 알아야 EIGRP가 보인다.

알고리즘, 경로결정, 수렴에 대한 차이점을 설명하고있다.



EIGRP 메시지 형식

OP코드 : update, query, reply, hello 의 번호가 지정이 되어있다.
AS 번호 : 파라미터는 자율시스템넘버이지만 EIGRP 라우팅 프로세스 ID값이 저장된다.


TLV (Type / Length / Values)

Type = 0x0001     -> EIGRP 파라미터
Type = 0x0102     -> IP 내부 경로
Type = 0x0103     -> IP 외부 경로

다 외울필요는 없지만 Type별 구분은 가능해야한다.







 
RTP (Reliable Transport Protocol) : EIGRP 패킷의 전달과 수신을 위해 사용하는 프로토콜이다.

RTP는 패킷을 유니캐스트 또는 멀티캐스트로 보낼 수 있다.

멀티캐스트 EIGRP 패킷은 224.0.0.10의 예약된 멀티캐스트 주소를 사용한다.

RTP는 TCP나 UDP와 유사하게 EIGRP 패킷 전달을 신뢰적으로도 또는 비신뢰적으도 전달한다.
이 말은 즉, RTP 에서는 신뢰적인 전달을 할때는 ACK를 보내 응답확인을 하고 비 신뢰적일때는 ACK패킷을 보내지 않는다.





Hello 패킷
EIGRP로 동작하는 라우터 간에 EIGRP 패킷을 교환하려면 라우터는 우선 자신의 neighbor를 발견해야 한다.
EIGRP neighbor란 직접 연결된 공유 네트워크상에서 EIGRP를 실행하고 있는 다른 라우터이다

EIGRP 라우터는 hello 패킷을 이용하여 neighbor를 발견하고 이들 라우터와의 인접 관계를 설정한다.

Default hello 전송 주기

T1, 이더넷 인터페이스와 같은 네트워크는 5초마다 전송
Frame-relay, ATM, X.25 인터페이스와 같은 네트워크는 60초마다 전송

hold time은 hello 주기의 3배이다. 만약 hold time이 만료된다면 해당 경로를 다운된 것으로 선언하고
DUAL을 이용하여 토폴로지 테이블내에서 새로운 경로를 검색하거나 query를 보내 새로운 경로를 검색.





제한된 EIGRP 업데이트
EIGRP 업데이트 패킷은 부분적인 (partial) 업데이트 패킷과 제한된 (bounded) 업데이트 패킷이 있다.
부분적인 (partial) 이라는 용어는 경로 변화에 대한 정보만을 포함하는 업데이트를 말한다.
제한된 (bounded) 이라는 용어는 부분적인 업데이트에 영향을 받는 라우터들에게만 업데이트가 전달된다는 것을
의미한다.

필요한 라우팅 정보만을 이를 필요로 하는 라우터들에게만 전달함으로써 EIGRP는 EIGRP 패킷 전송에 소요되는 대역폭을 최소화하고 있다.




EIGRP AD

EIGRP 요약경로 - 5
EIGRP 내부경로 - 90
EIGRP 외부경로 - 170




AS (Autonomous System, 자율 시스템) : 단일 기간의 관리 하에 있는 네트워크 장치들의 집합

 

프로세스 ID

Router(config)#router eigrp autonomous-system

eigrp 파라미터를 autonomous-system으로 참조하고 있지만 EIGRP 프로세스 ID 라고 생각하면 된다.

EIGRP에서는 이웃 관계 (neighbor adjacency) 확립을 위해 같은 라우팅 영역 내의 모든 라우터들은
동일한 프로세스 ID를 가져야 한다


RIP에서 프로세스 ID를 사용하지 않은 이유는 오직 하나의 라우팅 프로토콜만을 지원하기 때문이다.
EIGRP와 OSPF는 복수개의 라우팅 프로토콜을 구현하는것이 일반적이거나 권장 사항은 아니지만 가능하다.



network 명령어

router eigrp 1   -> eigrp 설정 모드로 접속
network 172.16.0.0   -> 광고하고자 하는 네트워크 설정 (두가지 방법이 있다)

서브넷마스크를 설정하지 않으면 클래스 풀 네트워크로 설정이 되고 특정 네트워크를 설정하고 싶으면
와이들카드 마스크를 적어주면 된다.

router eigrp 1이라는 동일한 프로세스 ID를 가지고 있는 인접한 라우터가 있으면 가장 아래와 같이 neighbor가 형성 되었다는 로그가 뜬다.


network address [wildcard mast]

EIGRP를 특정 서브넷에 대해서만 설정하고자 할 경우에는, network 명령어에 wildcard-mask 옵션을 사용한다.

Router(config-router)#network network-address [wildcard-mask]


ex)
192.168.10.8 255.255.255.252 
 -> 와일드카드 마스크 적용  :  
R2(config-router)#network 192.168.10.8 0.0.0.3



EIGRP 검증

show ip eigrp neighbors 명령어를 이용하면 neighbor 테이블을 볼 수 있고 EIGRP가 neighbor와 인접 관계를 확립했음을 확인할 수 있다. 각각의 라우터에서 인접 라우터의 IP 주소, 그리고 EIGRP neighbor와 통신하기 위해 사용하는 인터페이스 정보를 볼 수 있다.





show ip protocols 명령어는 라우팅 프로토콜에 따라 서로 다른 종류의 출력을 보인다.

EIGRP의 process ID가 출력에 포함되어 있다    ->  Routing Protocol is "eigrp 1"

process ID는 라우터 간의 neighbor 관계 형성과 라우팅 정보 교환을 위하여 모든 라우터에서
같은 값이어야 함에 주의한다.


EIGRP의 내부 및 외부 AD 또한 볼 수 있다.       ->
Distance: internal 90 external 170



show ip route 명령어를 이용하여 라우팅 테이블을 검사할 수 있다.
EIGRP 경로는 라우팅 테이블에서 DUAL을 의미하는 D로 표시된다.




라우팅 테이블에 NULL0 인터페이스 존재 이유

EIGRP는 다음과 같은 두 개의 조건이 만족할 때는 언제나 Null0 요약 경로를 자동적으로 자식 경로로 포함한다.
 - EIGRP를 통해 학습한 적어도 한 개 이상의 서브넷이 있음
 - 자동 요약 기능이 활성화 되어 있음

자동 요약 기능을 해제하면 Null0 요약 경로는 삭제된다.

어떤 패킷이 레벨 1 부모 (classful 네트워크 주소)와는 일치되지만 해당 서브넷 중에는 일치되는 것이 없으면
이 패킷은 폐기된다.



null0 요약 경로는 종종 자동으로 EIGRP에 포함되는가?


EIGRP를 라우팅 소스로 가지는 자식 경로가 적어도 하나 존재하고 디폴트 auto-summary 명령어가 사용될 때,
null0 요약 경로는 eigrp에 의해 자동적으로 라우팅 테이블에 추가된다.

예를 들어 10개의 주소를 하나의 요약된 경로를 가지고 있다. 그러나 요약 경로 10개중 하나의 경로가 끊어졌다. 하지만 라우팅 테이블에는 그대로 요약된 경로 그대로 가지고 있을것이다. 그러면 요약된 경로때문에 보내지만 실제로는 전송이 되지 않는다. 이런 모순된 상황에서 일어나는 비 정상적인 라우팅을 차단하기 위해서 NULL0 인터페이스로 패킷을 폐기한다.





다음 EIGRP 2에서는

EIGRP 메트릭 계산 및 상수 , DUAL , 자동요약 , 수동요약 , EIGRP Default 경로 전파에 대해 포스팅합니다.



'공부' 카테고리의 다른 글

[Network] VTP (Vlan Trunking Protocol)  (0) 2013.10.31
EIGRP 1  (0) 2012.02.24
RIPv2  (0) 2012.02.24
CIDR 경로요약  (0) 2012.02.24
RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
0 0
공부





RIPv2


 

RIPv2클래스리스 라우팅 프로토콜이다.

RIPv2가 어떤 환경에서는 적합할 수 있지만 EIGRPOSPF, IS-IS와 같이 더욱 많은

기능과 확작성을 가지는 프로토콜들과 비교했을 때 대중성이 떨어지게 된다.

다른 라우팅 프로토콜보다 조금 덜 사용되기는 하지만 RIP이 가지는 단순함과

많은 운영체제에서 널리 사용된다는 점에서 아직까지도 유용한 프로토콜이다. 

RIPv1의 가장 주요한 한계는 클래스풀 라우팅 프로토콜이라는 것이다.

클래스풀 라우팅 프로토콜은 라우팅 업데이트에서 네트워크 주소에 서브넷 마스크를

포함하지 않는다. 이것은 불연속적인 서브넷이나 VLSM을 사용하는 네트워크에서

문제점을 일으킬 수 있다.

RIPv2는 클래스리스 라우팅 프로토콜이기 때문에, 라우팅 업데이트에 서브넷

마스크가 포함된다. RIPv2는 완전히 새로운 프로토콜이라기보다는

사실상 RIPv1의 기능을 확장한 것이라고 보면 된다.

RIPv1, RIPv2 모두 디스턴스 벡터 라우팅 프로토콜이기때문에 디스턴스 벡터 계열의

속성을 그대로 적용받는다.


사설 IP 주소



루프백 인터페이스 (loopback interface)

인터페이스를 본뜨기 위해 사용하는 소프트웨어 전용 인터페이스이다.
IP 할당이 가능하고 특정한 라우팅 프로토콜에서는 라우터 ID가 된다.

물리적인 인터페이스 없이도 추가적인 네트워크를 생성할 수 있고 루프백 인터페이스로 핑을 보낼 수 있다.

널 인터페이스 ( null interface)

생성하기위해 어떤 명령어를 입력할 필요가 없다.
항상 활성화 된 상태이지만 트래픽을 전송하거나 수신하지는 않는다.

널인터페이스로 전송된 트래픽은 버려지게 된다.


경로 재분배 (redistribute)

하나의 라우팅 프로토콜로부터 경로들을 취해서 다른 라우팅 프로토콜로 전달하는 것에 관여한다.



RIPv1 의 제한사항


1. 불연속적인 네트워크

서브넷 마스크가 업데이트에 포함되지 않기 때문에, RIPv1과 그 밖의 클래스풀 라우팅 프로토콜은
메이저 네트워크 경계에서 반드시 네트워크들을 요약해야 한다
.


2. VLSM을 지원하지 않는다.

RIPv1은 라우팅 업데이트에 서브넷 마스크를 전송하지 않기 때문에 VLSM을 지원할 수 없다.


3. CIDR을 지원하지 않는다.
 

클래스풀 라우팅 프로토콜은 CIDR 경로를 지원할 수 없다.

CIDR는 해당 경로의 클래스풀 마스크보다 작은 서브넷 마스크로 요약된 경로이다.

RIPv1은 라우팅 테이블에 있는 이러한 수퍼넷을 무시하게 되고 다른 라우터로 보내는 업데이트에
이것을 포함하지 않는다
.


RIPv1 - RIPv2 메시지 형식 비교




RIPv2 설정




RIPv1의 제한사항 문제해결

1. 불연속적인 네트워크  ->  자동요약 비 활성화

no auto-summary 명령어를 사용하여 자동요약을 비 활성화 시켰다.
R2는 더이상 요약된 경로를 받지않고 상세정보를 전달 받게 된다.



2. VLSM 

RIPv2는 클래스 리스 라우팅 프로토콜이기 때문에 VLSM을 지원한다.
라우팅 정보 업데이트시 서브넷 마스크를 포함하여 전송하고 있다.




3. CIDR

요약된 주소를 redistribute 라는 명령어로 RIP 으로 재분배하였다.
RIPv1은 CIDR을 지원하지 않기 때문에 자신의 라우팅 정보를 전송할때 요약된 경로를 포함하지 않았다.
하지만 RIPv2는 CIDR을 지원하기 때문에 아래의 그림과 같이 라우팅 정보에 경로를 포함하고 있다.




문제해결에 명령어

show ip route 
라우팅 테이블을 확인할수 있는 명령어

show ip interface brief
요약된 인터페이스 활성화 검증 명령어

ping
연결성 테스트 명령어


show ip protocols
라우팅 프로토콜의 정보를 확인할수 있는 명령어

debug ip rip
라우팅 업데이트 내용을 확인할수 있는 명령어


show running-config
전반적인 설정사항을 확인하기 위한 명령어


'공부' 카테고리의 다른 글

[Network] VTP (Vlan Trunking Protocol)  (0) 2013.10.31
EIGRP 1  (0) 2012.02.24
RIPv2  (0) 2012.02.24
CIDR 경로요약  (0) 2012.02.24
RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
0 0
공부




클래스 상위비트 및 IP주소 범위




CIDR 의 특징

 - IPv4 주소 공간을 더 효율적으로 사용
 - 프리픽스 통합을 통해 라우팅 테이블의 크기를 감소

 


요약 계산방식


 

CIDR

 - default 클래스풀 마스크 보다 더 적은 마스크들을 사용해서 요약한다.
 - 라우팅 업데이트 안에 있는 엔트리들의 수를 감소 
 - 로컬 라우팅 테이블에 있는 엔트리들의 수를 감소 
 - 라우팅 업데이트들에 대한 대역폭 이용률을 감소
 - 더 빠른 라우팅 테이블 룩업을 가능

 
단! 클래스풀 라우팅 프로토콜은 VLAM, CIDR을 지원하지 않는다.
필히 클래스 리스 라우팅 프로토콜을 사용해야 한다.


'공부' 카테고리의 다른 글

EIGRP 1  (0) 2012.02.24
RIPv2  (0) 2012.02.24
CIDR 경로요약  (0) 2012.02.24
RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
정적경로  (0) 2012.02.24
0 0
공부



 RIPv1


 

RIP은 그 단순함과 광범위한 지원으로 인해 여전히 많이 사용된다.



RIP 주요 특징

1. RIP은 거리 벡터 라우팅 프로토콜이다.

2. RIPAD값은 120 이다.

3. RIP은 경로 선택을 위해 메트릭으로서 홉 카운트만을 사용한다.

4. 15보다 큰 홉 카운트를 가지는 라우트에는 도달할 수 없다고 사료된다.

5. 메시지 (라우팅 테이블 업데이트)는 매 30초 마다 브로드캐스트 된다.


RIP 기본 설정
Router(config)# router rip             -> RIP 활성화


불필요한 업데이트 중지
Router(config)# router rip     -> RIP 설정모드 접속
Router(config-router)# passive-interface fa 0/0     -> Fa 0/0 으로 업데이트 차단


자동요약
RIP은 메이저 네트워크 경계를 넘을때 자동으로 클래스풀 네트워크를 요약하는
클래스풀 라우팅 프로토콜이다.

자동 요약 장점
 - 더 작은 크기의 라우팅 업데이트들을 보내고 받으므로 더 적은 대역폭을 사용.
 - 하나의 경로를 사용하기 때문에 라우팅 테이블에서 빠른 룩업이 가능

자동 요약 단점
 - 불연속 네트워크를 지원하지 않는다.


RIPv1 에서 Default Route 전파
Router(config)# router rip
Router(config-router)# default-information originate
                             -> RIP 업데이트 안에 정적 디폴트 라우트를 전파한다.

라우팅 테이블에서 R*   -> RIP으로 전파받은 디폴트 라우트

Router(config-router)# network x.x.x.x      -> 광고하고자하는 네트워크

Router(config)# no router rip         -> RIP 비활성화



라우팅 테이블 확인

Router# show ip route


 1           2      3    4   5         6                     7               8

1. 라우팅 프로토콜 ( RIP으로 동작 )
2. 네트워크 주소 ( 클래스풀 )
3. 서브넷마스크
4. AD값 (RIP - 120)
5. Metric (RIP - 홉 카운트)
6. Next-hop IP 주소
7. 업데이트 경과 시간
8. 출구 interface

'공부' 카테고리의 다른 글

RIPv2  (0) 2012.02.24
CIDR 경로요약  (0) 2012.02.24
RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
정적경로  (0) 2012.02.24
라우팅 네트워크의 종류  (0) 2012.02.24
0 0
공부



Load Balancing ( 부하분산)
 - 동일한 네트워크로 가는 메트릭 값이 같은 경로가 복수개 존재할 때, 이 복수개의 경오를 동시에 사용하는 것을 말한다.

IOS 12.4 -> 최대 16개까지 부하분산 가능
IPv6 -> 64개까지 부하분산 가능

스위칭
 - 수신한 패킷을 목적지로 가는 인터페이스로 전송하는 것을 말한다.

스위칭 방식
 - 프로세스 스위칭, 패스트 스위칭, CEF      -> 방식 확인방법은 router# show ip interface serial 0/0


프로세스 스위칭
 - 패킷을 전송할 때마다 라우팅 테이블을 확인한 후 넥스트 홉을 결정하여 패킷을 전송하는 방식
 - 패킷별로 부하를 분산시킨다. 
 - 라우터 CPU에 많은 부하가 걸리며, 스위칭 속도도 느리다.
 - 링크의 활용도가 가장 높은 방식이다.
 - 패킷이 목적지에 도달하는 순서가 뒤바뀔 수 있어 특별한 경우가 아니면 사용하지 않는다.

R1(config)# interface serial 0/0
R1(config-if)# no ip route-cache      -> 프로세스 스위칭 활성화


패스트 스위칭
 - 처음은 라우팅 테이블을 참조하고, 두 번째 패킷부터는 캐시 정보를 이용하는 전송방식
 - 목적지별로 부하 분산을 한다. 즉, 목적지 IP주소가 같으면 모두 동일 interface로 전송한다.
 - 프로세스 스위칭에 비해 속도가 빠르다
 - 본사의 주 서버, 화상회의용 서버등 다수의 클라이언트들이 하나의 목적지 주소로 전송하는 경로는 사용하지 말아야 한다.

R1(config)# interface serial 0/0
R1(config-if)# ip route-cache         -> 패스트 스위칭 활성화


CEF
 - 패스트 스위칭 방식을 개선한 것
 - 처음부터 라우팅 테이블을 캐시로 복사해 놓는다.
 - 출발지 IP주소와 목적지 IP주소를 사용하여 hash 알고리듬을 적용한 다음 출력 인터페이스를 결정한다. (출발지-목적지별로 부하 분산)
 - 목적지 IP주소가 동일해도 출발지 주소가 다르면 서로 다른 인터페이스를 통하여 전송된다.

R1(config)# ip cef

R1# show ip cef     ->cef 테이블 확인

 - 파일전송 등으로 인하여 특정한 두 호스트간에 전송하는 경우엔 효율적인 부하 분산이 이루어 지지 않는다    
    -> CEF 스위칭에서 패킷별 부하분산을 시키면 문제 해결

R1(config)# interface serial 0/0
R1(config-if)# ip load-sharing per-packet



'공부' 카테고리의 다른 글

CIDR 경로요약  (0) 2012.02.24
RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
정적경로  (0) 2012.02.24
라우팅 네트워크의 종류  (0) 2012.02.24
경로결정  (0) 2012.02.24
0 0
공부



장점
 - 라우팅 프로토콜 자체로 인한 부하가 거의 없다
 - 경로를 네트워크 관리자의 의도대로 정밀하게 제어할 수 있다.

단점
 - 네트워크 변화를 제대로 반영하지 못한다.
 - 네트워크 규모가 커지면 설정 및 관리가 어렵다.


기본적인 정적 경로 설정

router(config)# ip route [목적지 네트워크] [서브넷] [next-hop 주소 / interface 설정]

router(config)# ip route 1.1.10.0 255.255.255.0 1.1.15.2         -> 1.1.10.0 네트워크로 가려면 1.1.15.2 로 전송

router(config)# ip route 1.1.10.0 255.255.255.0 serial 0/0      -> 1.1.10.0 네트워크로 가려면 serial 0/0 으로 전송

S    1.1.10.0/24  [1/0]  via 1.1.15.2 


default route를 이용한 정적 경로 설정

router(config)# ip route 0.0.0.0 0.0.0.0 1.1.15.2         -> 라우팅 테이블에 상세 네트워크가 존재하지 않는 패킷들은 1.1.15.2로 전송

router(config)# ip route 0.0.0.0 0.0.0.0 serial 0/0      -> 라우팅 테이블에 상세 네트워크가 존재하지 않는 패킷들은 serial 0/0 으로 전송

S*   0.0.0.0/0 [1/0] via 1.1.15.2


ip default-network 를 사용하여 default route 설정

router(config)# ip default-network 100.0.0.0
router(config)# ip route 100.0.0.0 255.0.0.0 1.1.15.2

S*  100.0.0.0/8  [1/0]  via 1.1.15.2



디폴트 게이트웨이 
 - 보통때는 동작하지 않다가, no ip routing 명령어가 사용된 경우 라우팅 기능이 정지되면 동작한다.


플로팅 스태틱 루트
 - 주 라인이 다운됬을 경우에 설치되는 경로를 말하고 주 라인보다 높은 AD값을 가지면 된다.













'공부' 카테고리의 다른 글

RIPv1  (0) 2012.02.24
스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
정적경로  (0) 2012.02.24
라우팅 네트워크의 종류  (0) 2012.02.24
경로결정  (0) 2012.02.24
라우팅 프로토콜의 종류  (0) 2012.02.24
0 0
공부




라우팅 프로토콜들이 라우팅 관련 패킷을 전송할 때 브로드캐스트, 멀티캐스트 또는 유니 캐스트방식을 사용한다.

브로드 캐스트
 - 목적지 주소가 255.255.255.255로 설정된 전송 방식으로 모든 장비가 수신자가 된다.

멀티 캐스트
 - 목적지 주소가 224.0.0.0 ~ 239.255.255.255로 설정된 전송 방식으로 특정 그룹만이 패킷을 수신한다.
    RIPv2(224.0.0.9), EIGRP (224.0.0.10), OSPF (224.0.0.5 , 224.0.0.6)

유니 캐스트
 - 목적지 주소가 특정 IP 주소가 지정된 전송방식이다.


브로드캐스트 멀티액세스 네트워크
 - 하나의 브로드 캐스트 패킷을 전송하면 동일 네트워크내에 있는 모든 장비에게 도달할 수 있는 네트워크를 브로드캐스트 라고하며, 하나의 인터페이스를 통하여 다수의 장비와 연결되는 네트워크를 멀티액세스 라고 한다. 즉 브로드 캐스트를 지원하면서 멀티 액세스가 가능한 네트워크를 브로드캐스트 멀티 액세스 (broadcast multi-access) 네트워크라고 한다.
 - 대표적 : 이더넷(ethernet)


NBMA (non-broadcast multi-access)
 - 브로드캐스트 기능이 지원되지 않는 멀티 액세스 네트워크를 말한다. 대표적인 NBMA 네트워크로는 ATM, X.25, FR 네트워크
 - 대부분 비 브로드캐스트 네트워크는 내부에서 가상회로(virtual circuit) 방식을 사용하여 멀티 액세스를 구현한다.
 - 가상회로 번호의 이름은 인캡슐레이션 방식마다 다르며, 프레임 릴레이에서는 DLCI 라고 한다.


포인트 투 포인트 네트워크
 - 하나의 인터페이스 또는 서브 인터페이스와 연결되는 상대 장비가 하나뿐인 네트워크를 말한다. 레이어 2 프로토콜이 HDLC, PPP등인 시리얼 인터페이스, 프레임 릴레이 포인트 투 포인트 서브 인터페이스등이 대표적인 포인트 투 포인트 네트워크이다.
 - 이때 목적지 주소를 브로드캐스트, 멀티캐스트 또는 유니캐스트 주소중 어떤 것을 사용하여도 상관 없다.







'공부' 카테고리의 다른 글

스위칭 방식별 부하 분산(load balancing)  (0) 2012.02.24
정적경로  (0) 2012.02.24
라우팅 네트워크의 종류  (0) 2012.02.24
경로결정  (0) 2012.02.24
라우팅 프로토콜의 종류  (0) 2012.02.24
라우팅 개요  (0) 2012.02.24
0 0
공부

 



경로 결정 방법

복수개의 라우팅 프로토콜이 설정된 라우터에서 특정 목적지로 가는 경로는 아래와 같은 기준과 절차에 의해서 결정된다.

1. 동일 라우팅 프로토콜내에서 특정 목적지로 가는 경로가 복수개 있을 때 메트릭이 가장 낮은 것이 선택된다.

2. 복수개의 라우팅 프로토콜들이 계산한 특정 네트워크가 라우팅 테이블에 저장될 때는 AD 값이 가장 낮은 것이 선택된다.

3. 라우팅 테이블에 저장된 다음 패킷의 목적지 주소와 라우팅 테이블에 있는 네트워크 주소가 가장 길게 일치되는 경로가 선택.



1. 메트릭(Metric)
 라우팅 프로토콜별로 사용하는 메트릭

 라우팅 프로토콜  메트릭
 RIP 홉 카운트 
 EIGRP  속도, 지연, 신뢰도, 부하, MTU
 OSPF  코스트(속도)
 BGP  Attribute

RIP의 홉카운트는 네트워크에 도달할 때까지 거쳐야 하는 라우터의 수를 말한다.

OSPF의 코스트는 속도가 빠를 수록 그 값이 적다.


2. AD(Administrative Distance)
 : 하나의 라우터에서 동시에 2가지 이상의 라우팅 프로토콜을 사용하면 AD값이 낮은 라우팅 프로토콜이 라우팅 테이블에 저장

라우팅 프로토콜별 AD값
 라우팅 프로토콜에 따른 경로의 종류 AD 
직접 접속된 네트워크
로컬 인터페이스를 사용한 정적 경로 0
넥스트 홉 IP 주소를 사용한 정적 경로
EIGRP 축약 경로 (summary route) 5
외부 BGP 20
내부 EIGRP 90 
OSPF 110 
IS-IS 115 
RIP 120 
외부 EIGRP 170 
내부 BGP 200 


3. 라우팅 테이블
 : 라우터가 목적지 네트워크별 출력 인터페이스와 넥스트 홉 IP주소를 저장해 놓은 데이터 베이스

4. 롱기스트 매치 룰
 : 라우터가 패킷을 라우팅 시킬 때 패킷의 목적지 주소와 라우팅 테이블의 목적지 주소가 일치하는 부분이 가장 긴곳 으로 전송


정리
 - 이처럼 특정 패킷을 라우팅 시키기 위하여 동일 라우팅 프로토콜 내에서 메트릭 경쟁을 하고, 서로 다른 라우팅 프로토콜간에 AD 경쟁을 거쳐 목적지 네트워크가 라우팅 테이블에 저장된 다음, 최종적으로 롱기스트 매치룰을 적용한다.



'공부' 카테고리의 다른 글

정적경로  (0) 2012.02.24
라우팅 네트워크의 종류  (0) 2012.02.24
경로결정  (0) 2012.02.24
라우팅 프로토콜의 종류  (0) 2012.02.24
라우팅 개요  (0) 2012.02.24
[Academy] chapter 6 _ 8. VLSM-CIDR / Routing Table  (0) 2012.02.24
0 0
1 2 3 4 ··· 6
블로그 이미지

황영종

황영종